Forum

Créations de Modules » Vos Modules Notifications | PHPBoost 5.1

MickaelFR Membre non connecté

Booster Missile

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1366

Le 11/01/2019 à 19h23

Reprise du message précédent

oui oui

je vois bien les déclarations, mais ça n’apparaît pas. J'ai repris tous les fichiers neufs. Et j'ai re-modifié comme j'avais fait. Edité par MickaelFR Le 11/01/2019 à 19h24
Myster Membre non connecté

Booster Mortier

Rang

Avatar

Inscrit le : 04/10/2010 à 19h18

Messages: 907

Le 11/01/2019 à 19h25
Donc si j'ai bien compris, dans le mini module tu n'as plus "Vous avez X notifications " ?

Tu peux me donner ton tpl ?
Site web    
MickaelFR Membre non connecté

Booster Missile

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1366

Le 11/01/2019 à 19h32
Oui c'est bien ça, je viens de le remplacer à nouveau, et reupload, et même chose. J'ai que le "1" :D

NotificationsModuleMiniMenu.rar
Myster Membre non connecté

Booster Mortier

Rang

Avatar

Inscrit le : 04/10/2010 à 19h18

Messages: 907

Le 11/01/2019 à 19h48
Voici le correctif

Code TPL :
 
        # IF C_NOTIFICATION #
            <p>${LangLoader::get_message('notification.you.have', 'common', 'notifications')} <span style="color:red;">{NBR_NOTIFICATIONS}</span> ${LangLoader::get_message('notifications', 'common', 'notifications')}</p>
            # ELSE #
            <p>${LangLoader::get_message('no_notification', 'common', 'notifications')}</p>
        # ENDIF #
 
        <a class="small" href="{U_NOTIFICATIONS}">{@my.notifications}</a>
 


Je mettrais à jour demain les archives
Site web    
MickaelFR Membre non connecté

Booster Missile

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1366

Le 11/01/2019 à 19h50
C'est super :top

Je pensais que ça venait ENCORE de moi :D

Merci Myster :)
Myster Membre non connecté

Booster Mortier

Rang

Avatar

Inscrit le : 04/10/2010 à 19h18

Messages: 907

Le 11/01/2019 à 19h54
Mais de rien :)
Site web    
MickaelFR Membre non connecté

Booster Missile

Rang

Avatar

Inscrit le : 20/01/2014 à 11h01

Messages: 1366

Le 11/01/2019 à 19h59
Si si, vraiment :)
Sympa Membre non connecté

Booster Bazooka

Rang

Avatar

Inscrit le : 23/08/2018 à 12h09

Messages: 175

Le 13/01/2019 à 01h45
Merci Myster et félicitations


Le savoir se partage!
La communauté des élèves et étudiants de l'Afrique sur https://www.webstudycorner.com

Site web    
Myster Membre non connecté

Booster Mortier

Rang

Avatar

Inscrit le : 04/10/2010 à 19h18

Messages: 907

Le 13/01/2019 à 10h54
Merci et de rien :)
Site web    
Alexoune001 Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 22/01/2013 à 17h30

Messages: 41

Le 16/01/2019 à 00h55
Bonsoir,

Hm j'ai installer correctement le module, j'ai effectué toutes les modifications pour les addons. Seulement, j'ai des erreurs lors ce que je veux envoyer une notification via le panel d'administration, j'obtiens cette erreur (mode débug activé) :
Citation :
Argument 1 passed to Notifications::set_sender_id() must be an instance of int, string given, called in C:\UwAmp\www\notifications\controllers\AdminNotificationsFormController.class.php on line 55 and defined


Et si je réponds par exemple au sujet qui a été créé automatiquement après l'installation de phpboost, avec un nouvel utilisateur, j'obtiens ce message d'erreur :
Citation :
Argument 1 passed to Notifications::set_sender_id() must be an instance of int, string given, called in C:\UwAmp\www\forum\post.php on line 343 and defined


Alexoune001, Fondateur du MMORPG : Drastal Online.
Site web    
Myster Membre non connecté

Booster Mortier

Rang

Avatar

Inscrit le : 04/10/2010 à 19h18

Messages: 907

Le 16/01/2019 à 08h19
Bonjour,

Oui j'ai eu connaissance de ce problème (Merci Swan) Parce que tu utilises PHP5 je vais mettre à jour les différentes archives.

Ce qui se passe en fait c'est que le module utilises certaines fonctions de PHP7 du coup rendant incompatible le module avec les versions antérieurs de PHP 7, je ferait la maj dans la journée Edité par Myster Le 16/01/2019 à 08h20
Site web    
Alexoune001 Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 22/01/2013 à 17h30

Messages: 41

Le 16/01/2019 à 14h38
Bonjour,

Ah oui d'accord, pas de soucis :)

Je vais mettre Php 7 du coup le temps que tu fasses la MàJ :)


Alexoune001, Fondateur du MMORPG : Drastal Online.
Site web    
olivierb Membre non connecté

Booster Missile

Rang

Avatar

Equipe Assistance

Inscrit le : 07/02/2014 à 21h54

Messages: 1408

Le 16/01/2019 à 15h45
Bonjour,

Autant que tu restes en PHP7 pour profiter pleinement de ses fonctionnalités bien que PHPBoost soit valide à partir de PHP 5.6 ;)
Il me semble avoir entendu que certains hébergeurs parlent de supprimer la v5 de PHP.

Olivier. Edité par olivierb Le 16/01/2019 à 15h46


Olivier
Site web    
Alexoune001 Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 22/01/2013 à 17h30

Messages: 41

Le 16/01/2019 à 16h16
Bonjour,

Oui exacte, je vais rester directement sur PHP 7 :)
Ah je n'ai pas entendu parlé pour les hébergeurs, mais c'est possible je pense (en même temps cette version commence à se faire vieille petit à petit ^^)


Alexoune001, Fondateur du MMORPG : Drastal Online.
Site web    
Swan Membre non connecté

Booster Mortier

Rang

Avatar

Inscrit le : 31/05/2013 à 12h34

Messages: 768

Le 16/01/2019 à 19h32
Bonsoir,

@Olivier :: Oui mais c'est pas cool pour ceux qui reste sur des dédier en 5.6 , et on est certainement pas les seuls. Nous, nos 2 dédiés son en 5.6.. C'est bien de viser haut, mais de rester accessible aussi ..

Enfin bref ce que j'en dit moi. c'est dommage d'avoir des module mais que pour ceux qui seront en PHP7, je trouve cela un peu élitiste comme méthode.

:what Donc je me demande si cela vaut bien le coup que je test les modules.

Swan. Edité par Swan Le 16/01/2019 à 19h34
Site web    
olivierb Membre non connecté

Booster Missile

Rang

Avatar

Equipe Assistance

Inscrit le : 07/02/2014 à 21h54

Messages: 1408

Le 16/01/2019 à 20h56
@swan,

Je n'ai jamais dit qu'il "fallait" passer à PHP7, j'ai simplement répondu à Alex que comme il dispose de PHP7, autant qu'il s'en serve.

Faut pas laisser entendre ce que je n'ai pas dit, c'est pas bien :(

Olivier.


Olivier
Site web    
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie