Forum

Support des Modules [Réglé] Module "Articles" : Page blanchee Manips dans articles et bug présumé ?

charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 11/03/2020 à 21h15

Bonjour à tous, :)

J'avance dans la découverte de Phpboost et, aprés une migration apparemment réussie (dans un autre sous domaine sur le même serveur), je rencontre un problème de page blanche en voulant changer mes articles de catégorie.

Je pense que le module "Article" est en cause (?) car quand je le désactive, tout redevient à la normale. Sans articles off course. :-//

Système d'exploitation : Ubuntu 18.04.4 LTS
Navigateur Web : Firefox/Chrome
Version de test (Site de test)
Installation  serveur web :O2switch
Lien :*ttps://membres.orgues-barbarie-toulouse.org

Pas d'erreurs archivées

---------------------------------System report---------------------------------
-----------------------------generated by PHPBoost-----------------------------
SERVER CONFIGURATION-----------------------------------------------------------
php version            : 5.6.40
dbms version            : MySQL 10.2.31-MariaDB
gd library            : 1
curl extension            : 1
mbstring extension        : 1
url rewriting            : 1
apcu cache            : 1
PHPBOOST CONFIGURATION---------------------------------------------------------
phpboost version        : 5.2.5
server url            : https://membres.orgues-barbarie-toulouse.org
site path            :
default theme            : Base (Version 5.2.0)
default language        : Français
default editor            : BBCode
home page            : https://membres.orgues-barbarie-toulouse.org/index.php
url rewriting            : 1
apcu cache            : 1
output gzip            : 1
session cookie name        : session
session duration        : 3600
active session duration        : 300
DIRECTORIES AUTHORIZATIONS-----------------------------------------------------
/                : 1
/cache                : 1
/cache/backup            : 1
/cache/syndication        : 1
/cache/tpl            : 1
/cache/css            : 1
/images/avatars            : 1
/images/customization        : 1
/images/group            : 1
/images/maths            : 1
/images/smileys            : 1
/kernel/db            : 1
/lang                : 1
/templates            : 1
/upload                : 1

J'ai passé des heures à tenter de comprendre mais là, je ne sais plus.

Une idée ou des pistes ?



La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
babsolune Membre non connecté

Modérateur

Rang

Avatar

Equipe Graphique

Inscrit le : 16/05/2008 à 12h52

Messages: 2411

Le 12/03/2020 à 04h54
Plop

Je viens de faire un test sur le site de demo et ça fonctionne correctement.
Je pencherai pour un ré-upload/ré-install du module en mode binaire http://prntscr.com/rf2i1z , histoire d'être sûr que le module est bien chargé.


Site web    
janus57 Membre non connecté

Booster Fusée

Rang

Avatar

Equipe Assistance

Inscrit le : 07/12/2007 à 07h16

Messages: 6483

Le 12/03/2020 à 05h14
Bonjour,

membres.orgues-barbarie-toulouse.org ==> ça pointe où sur le serveur ?
orgues-barbarie-toulouse.org ==> ça pointe où sur le serveur ?

PHP5.6 c'est un peu vieillot et plus maintenu par PHP, je vous conseil PHP7.3

Cordialement, janus57


hm35RAXMa boule de cristal est en panne. merci de donner les détails de votre problème
   
charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 12/03/2020 à 05h27

En voilà de bonnes idées et bonnes questions comme je les aime.

Demain, je vais essayer de re-uploader en mode binaire  et on verra ce que ça donne.

@janus57

orgues-barbarie-toulouse.org pointe vers un répertoire dans le WWW

membres.orgues-barbarie-toulouse.org pointe vers un répertoire hors WWW. C'est un sous domaine.

Pour le PHP7, j'hésite à upgrader l'hébergement total car j'y ais tout un tas de sites un peu viellots qui ne le supportent pas. Une bonne occasion pour faire du ménage. ;)

En fait, j'ai essayé de mettre une instruction dans le .htaccess pour passer le répertoire en PHP7.1 mais bizarement  PBT me le sucre au bout de quelques minutes et je me demande bien pourquoi ça fait ça. :-//.



La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
janus57 Membre non connecté

Booster Fusée

Rang

Avatar

Equipe Assistance

Inscrit le : 07/12/2007 à 07h16

Messages: 6483

Le 12/03/2020 à 05h56
Bonjour,

il faut passer par PHPBoost pour modifier le .htaccess, car à chaque vidage du cache PHPBoost réécrit le .htaccess avec ces instructions en fonctions de vos modules et de vos options (redirection/url rewrite/protection répertoire upload voir autre(s) fonctions dans le futur)

Cordialement, janus57


hm35RAXMa boule de cristal est en panne. merci de donner les détails de votre problème
   
charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 12/03/2020 à 06h40

Ben dis donc, je n'aurais jamais immaginé cela. Lol !

Bon, je vais me pencher sur la question car j'avais vu les contenus  .htaccess et robots.txt dans l'admin mais ne savais pas encore comment les utiliser. c'était la prochaine étape.

Je me demande si je n'ai pas trouvé mon bug.

Dans le tuto, j'avais zappé la ligne...

Ajoutez le dossier install à votre nouveau site et installez le nouveau site.

...et il aurait sans doute fallu réinstaller.

Là, ça charge et je vais refaire la manip.

Ensuite, j'essaye de dormir. Deux nuits blanches avec PBT. ;)

Edité par charleston Le 12/03/2020 à 06h41


La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 12/03/2020 à 07h09

C'est raté ! Toujours la page blanche sauf si je désactive le module Articles. :((

*ttps://membres.orgues-barbarie-toulouse.org/

Je vais me coucher.



La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 12/03/2020 à 16h11

Salut,

Rassurez-moi.

Ce tuto est bien d'actualité non ?

https://www.phpboost.com/wiki/changement-d-hebergement-ou-de-serveur



La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
janus57 Membre non connecté

Booster Fusée

Rang

Avatar

Equipe Assistance

Inscrit le : 07/12/2007 à 07h16

Messages: 6483

Le 12/03/2020 à 21h41
Bonjour,

Pour ma part je vous conseil celui-ci : https://www.phpboost.com/wiki/changement-d-h-bergement-ou-de-serveur-avec-phpmyadmin

Par contre je confirme que mode binaire obligatoire et FTPS ou SFTP, FTP normale à éviter.

Cordialement, janus57


hm35RAXMa boule de cristal est en panne. merci de donner les détails de votre problème
   
charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 12/03/2020 à 21h55

OK janus57 et merci pour le binaire. Je vais essayer cela comme cela. ;) 



La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 13/03/2020 à 01h32

Bon, il semble qu'il y ait bien un bug quelque part. Mon histoire de page blanche a recommencée avec exactement la même manip.

C'est quand je change un article de catégorie que ça se produit.

Par contre, si je le mets en brouillon et que je le change de catégorie, tout va bien sauf que si j'essaye de publier  dans une catégorie qui n'est pas celle d'origine, ça couaque encore (page blanche).

Je précise qu'il s'agit d'une nouvelle installation toute propre sur le même serveur (O2witch).

Qu'en pensez-vous ?

https://ressources.orgues-barbarie-toulouse.org/

 



La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
janus57 Membre non connecté

Booster Fusée

Rang

Avatar

Equipe Assistance

Inscrit le : 07/12/2007 à 07h16

Messages: 6483

Le 13/03/2020 à 05h16
Bonjour,

il faudrait reproduire le problème pour que l'on puisse regarder.
Là pour moi le site fonctionne.

Cordialement, janus57


hm35RAXMa boule de cristal est en panne. merci de donner les détails de votre problème
   
charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 13/03/2020 à 05h17

Vous voulez des identifiants ?



La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
janus57 Membre non connecté

Booster Fusée

Rang

Avatar

Equipe Assistance

Inscrit le : 07/12/2007 à 07h16

Messages: 6483

Le 13/03/2020 à 19h10
Bonjour,

dans l'idéal il faudrait un accès administrateur au site, un accès FTP et le site qui affiche la page blanche.

Cordialement, janus57


hm35RAXMa boule de cristal est en panne. merci de donner les détails de votre problème
   
charleston Membre non connecté

Booster Minigun

Rang

Avatar

Inscrit le : 06/03/2020 à 00h57

Messages: 45

Le 13/03/2020 à 19h22

Ok, je vous prépare ça pour le site en production et vous pourrez tester vous-même le bug au changement d'article de catégories.

Il semble que j'ai un autre problème avec le module téléchargement qui me donne une erreur quand j'intègre un mp3.

Une erreur s'est produite lors de l'opération

Je vous envoie un mp avec les identifiants tout à l'heure.

 



La vie, c'est autre chose !
https://orgues-barbarie-toulouse.org

   
Répondre
Vous n'êtes pas autorisé à écrire dans cette catégorie